Conviértete en todo un experto de VMware con nuestro taller de virtualización VMware vSphere Online
header banner
header banner
header banner
Formacion skypscraper
Servicios skypescraper

About the author

Florian Murillo

Florián Murillo es CTO y socio fundador de Cloud Consulting, consultora especializada en cloud computing y DataCenter, con mas de 25 años asesorando empresas de todos los tamaños y con amplia experiencia en Seguridad, Virtualización VMware (VCP5 y VCI5) y Networking de Cisco (CCNP, CCDP y CCSP). Actualmente se dedica a ayudar a desarrollar negocios y proyectos en la nube a integradores, consultoras y proveedores de servicio.

Related Articles

55 Comments

  1. 1

    José Luis Gómez Ferrer de Couto

    Hola Florian:

    Buen artículo, claro y conciso. Pero tengo una inquietud, cuando hablamos del método de balanceo apropiado para el vSwitch creado con más de 1 pNIC, tenemos varias opciones. ¿Es cierto que para usar IP Hash como método hay que tener los puertos del switch con LACP o Port-Channel?

    Saludos.

    Reply
  2. 2

    Florián

    Hola José Luis, para utilizar IP Hash, has de crear un port-channel obligatoriamente, pero no con LACP, sino NO NEGOTIATE, ya que los ESX no negocian LACP, PAgP, DTP ni nada por el estilo.

    Reply
    1. 2.1

      José Luis Gómez Ferrer de Couto

      Hola Florián:

      Muchas gracias, ciertamente para Cisco hay que usar etherchannel, pero hay que tener en cuenta que es un protocolo propietario de Cisco. Para el resto de dispositivos si podemos usar LACP ¿no?.

      Saludos.

      Reply
  3. 3

    Florián

    José Luis, el problema no está en Cisco, son los ESX/ESXi los que no hablan LACP, por tanto, independientemente del fabricante de networking, no se ha de configurar LACP en los puertos que se conectan a los switches. Salu2.

    Reply
  4. 4

    José Luis Gömez

    Hola Florián:

    Nuevamente gracias por la explicación. Estaba mirando el KB1004048 y estaba un poco confundido, ya que decía que para HP se configure en modo TRUNK, pero luego en la línea de comandos a teclear muestra la opción de LACP (y eso que pone claro TRUNK en negritas).

    Muchas gracias y buen fin de semana.

    Reply
  5. 5

    Florián

    jajaja feliz puente, olvídate de trunks y LACPs y disfruta de lo que los controladores aéreos nos dejen ;-)

    Reply
    1. 5.1

      Jose Maria Gonzalez

      Hola Florian, Jose Luis:

      Corregidme si me equivoco, pues el tema de la red no es muy fuerte, pero yo tenia la impresión que SI que hay que configurar un LACP pero en modo estático y no dinámico, ya que como apunta Florian el LACP en modo dinámico no esta soportado en VMware ESX/ESXi.

      Gracias,
      rgds,
      J.

      Reply
      1. 5.1.1

        José Luis Gómez Ferrer de Couto

        Hola JM:

        Yo tenía entendido que LACP había que activarlo cuando se iba a usar el balanceo por IP HASH y que tiene que ser en el mismo switch físico o stacking, no puede ser en switches separados. Entiendo que 802.3ad es la release antigua y que la nueva norma es 802.1.AX según comenta al menos en Wikipedia http://en.wikipedia.org/wiki/Link_aggregation.

        Teniendo eso en cuenta, según el siguiente KB1001938 de VMware, habla de la necesidad de como bien dices activar LACP en modo ESTÁTICO. En cisco se puede usar Ether-Channel.

        http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1001938

        Saludos e interesante color que coge el post :)

        Reply
  6. 6

    Florián

    Hola amigos, EtherChannel se puede configurar “a piñon fijo” o con un protocolo de negociación de agregación de interfaces al “channel” como PAgP (propietario de Cisco) o LACP, basado en el standard 802.3ad.
    Un port-channel se puede configurar en modo ON, es decir “a piñon fijo” sin protocolo de negociación, ACTIVE que conoce un protocolo de negociación PAgP o LACP (según lo hayamos configurado) e INICIA negociación para agregarse al port-channel, PASIVE que conoce el protocolo configurado y espera que el otro extremo sea ACTIVE para iniciar negociación.
    A todos los efectos la configuración PASIVE y ON tiene el mismo efecto para un ESX, pero si un ESX NUNCA va a negociar LACP ¿para que le das esta capacidad a un puerto?
    A mi modo de ver añadirás variables (innecesarias) a un escenario, y ante un problema tendrás mas variables que ecuaciones, y ya sabemos que quiere decir eso…

    Reply
    1. 6.1

      José Luis Gómez Ferrer de Couto

      Hola Florián:

      De acuerdo con lo que comentas, si tenemos Cisco configuramos Ether-channel y listo. Pero aunque no tenga que ver con este artículo, si no disponemos de un switch Cisco ¿cómo configuramos los puertos para poder usar IP HASH como balanceo?.

      Saludos.

      Reply
    2. 6.2

      Jose Maria Gonzalez

      Amen to that brother ;)

      Muchas gracias Florián

      rgds,
      J.

      Reply
  7. 7

    Florián

    Tendrás que ver las recomendaciones del fabricante, pero en cualquier caso, filtrado de las VLANs que han de circular, agregación sin negociación (forzada) y no spanning-tree hacia los ESX ;-)

    Reply
  8. 8

    Jose

    Hola Florian:
    Me quedó bastante más claro con este artículo; este tema me lleva por la calle de la amargura. Soy un poco novato en este tema y me ha surgido un problema. Te lo comento por si se te ocurriese que puede estar fallando.
    En mi infraestructura tengo 2 servidores cada uno con 2 tarjetas de red y están virtualizados con ESX 4.1. Hay actualmente 2 VLAN activas. Las tarjetas de red están en balanceo de carga para obtener una mayor ancho de banda (según he entendido) y 802.1q está habilitado.
    En la parte de la conmutación tengo un switch alcatel con el protocolo 802.1q habilitado en cada uno de los puertos que conectan con los servidores (en total 4 puertos). De este switch cuelgan otros dos que se encargan de dar servicio a los usuarios. El gran problema que tengo es que si conecto los 2 servidores simultaneamente en el switch toda la infraestructura se me cae.
    Supongo que será por algún bucle pero no localizo donde se produce.

    Reply
    1. 8.1

      José Luis Gómez Ferrer de Couto

      Hola José:

      Si conectas los servidores, pero únicamente con una tarjeta de red, ¿también se cae la red?.

      Recuerda que debes tener deshabilitado STP/RSTP en los puertos donde conectas los ESX(i) o en su defecto activar portfast.

      Un saludo.

      Reply
  9. 9

    Jose

    Se me olvidó. Gracias de antemano y un saludo.

    Reply
  10. 10

    Jose

    Hola José Luis:
    Sí incluso con una sola tarjeta de cada servidor se cae todo. El sistema ahora se ha quedado con todas las máquinas virtuales en un servidor y las dos tarjetas de red de éste conectadas al switch; he tenido que dejar fuera el segundo servidor.
    Voy a probar a deshabilitar STP y os comento el resultado. Si lo deshabilito ¿qué mecanismo utilizará la infraestructura para detectar los bucles y cortarlos?
    Otra duda que me surge es cómo funciona exactamente el balanceo de carga en vmware si reparte la carga de manera equilibrada por ambas tarjetas o es el propio mecanismo del balanceo el que proboca los bucles, no sé si me explico…

    Gracias y saludos.

    Reply
  11. 11

    José Luis Gómez Ferrer de Couto

    Hola:

    ¿Usas blades como servidores?

    Si conectas los servidores con una única tarjeta de red al switch no debe de producirse corte alguno. Otra opción es que pongas una NIC como activa y la otra como pasiva y ver el resultado.

    Recuerda el método de balanceo ha de ser PortID y si quieres usar IP Hash has de hacer un channel en los dos puertos del switch donde conectas el host ESX(i).

    Los bucles son cortados por STP/RSTP en el resto de puertos, en donde se encuentran los hosts ESX(i) no tiene que estar habilitado STP/RSTP o por lo contrario, ACTIVA portfast.

    ¿Qué alcatel usas?

    Saludos.

    Reply
  12. 12

    Florián

    @Jose, hola, veo que Jose Luis te lleva por el buen camino ;-) sigue sus recomendaciones, tengo una cuestión, tienes un switch y un host con 4 tarjetas conectadas a ese switch y funciona bien, pero cuando conectas el segundo servidor, al mismo switch, todo se cae ¿es así?

    Tienes los logs el switch Alcatel, nos dará una ayuda de incalculable valor

    Reply
  13. 13

    Jose

    Hola a todos, tengo un switch (alcatel 6400) y un host con 2 tarjetas conectadas. Cuando conecto la primera (este segudno host también tiene 2 tarjetas) tarjeta del segundo host es cuando todo se cae.
    Mañana a lo largo de la mañana busco el log del switch y os lo pego por aquí para que le echeis un ojo.
    Gracias

    Reply
    1. 13.1

      José Luis Gómez Ferrer de Couto

      Hola José:

      Lo que comentas en principio no es lógico, como bien te comentaba ¿qué tipo de servidores usas?.

      Si estás usando blades, ten cuidado con los switches de los chasis ya que estos también han de tener deshabilitado STP/RSTP. VMware no soporta estos protocolos.

      De todos modos, y si tienes oportunidad, hazte un write terminal y pegamos la configuración del switch, a ver si tiene algo raro.

      Saludos.

      Reply
  14. 14

    Jose

    No(ojala contara con un blade). Son dos servidores IBM independientes con una SAN como dispositivo de alamcenamiento todo conectado mediante este switch por iSCSI.
    Entonces en una VLAN tengo los equipos y servidores pero la SAN está en una VLAN distinta con lo que tiene que haber comunicación entre las VLAN´s.

    Igual te he liado más con esta explicación. Si no queda claro lo intento especificar un poco más.
    Gracias de nuevo.

    Reply
    1. 14.1

      José Luis Gómez Ferrer de Couto

      Hola José:

      Imagino que el tráfico iSCSI no lo estás sacando por las mismas NICs que tienes hecho el teaming.

      Respecto lo que dices del almacenamiento, la red SAN como buena práctica no debe verse con ninguna otra red.

      El escenario lo prepararía del siguiente modo dependiendo de 2 factores, si sólo tienes 2 NICs para todo o cuentas con más.

      Si sólo tienes 2 NICs haría lo siguiente, obviar la redundancia y dedicar una NIC para almacenamiento y la otra para producción de las VMs.

      Si tienes más de 2 NICs, siempre dejar reservada al menos una NIC para almacenamiento sin usar VLAN ID (que coja la nativa del switch Alcatel)

      De todos modos, vamos a intentar con lo que tienes ahora mismo. Los puertos donde conectas los ESX(i) dices que los tienes en modo trunk, ¿con cuál VLAN nativa?.

      Otra cosa que puedes hacer cuando conectas y se te cae todo es un “show spantree ports” y ver si tienes alguno en BLK

      Saludos.

      Reply
  15. 15

    Jose

    Por el momento cuento únicamente con dos NICs para todo en cada servidor y por lo que me comentaron los técnicos que lo configuraron en un primer momento lo mejor era redundar la conexión con lo cual todo el trafico pasa por estas dos NICs con el teaming hecho para su intercomunicación.

    Los puertos están conectados al switch en modo trunk permitiendo las dos VLAN. La VLAN nativa es la que usa por defecto Alcatel: la 1.

    Mañana probaré esto último que me comentas.

    Entonces tu propones dejar una de las NIC en la VLAN de almacenamiento y con la otra NIC hacer el teaming y dedicarla a la producción de las VMs.

    Saludos

    Reply
  16. 16

    José Luis Gómez Ferrer de Couto

    Hola José:

    Bajo mi punto de vista, deberías ampliar al menos a 4 NICs. Si usas además HA y vMotion iríamos a 6 – 8 NICs. También depende todo de lo crítico que sea el entorno.

    Una opción que puedes hacer, pero no sé que rendimiento te dará es lo siguiente. Se hace con otros servicios mezclados, pero no con producción de las VMs y la red de almacenamiento.

    En el vSwitch0 agregas las dos NICs como activas y balanceo PortID, donde tienes creados tres Port Groups (administración, VMs, almacenamiento). En los Ports Group de administración y producción sobreescribes la configuración de balanceo diciendo que vas a tener como activa la NIC1 y pasiva la NIC2. En el Port Group de almacenamiento configuras lo contrario, tienes como activa la NIC2 y pasiva la NIC1.

    De ese modo estás forzando que el tráfico SAN vaya por una NIC pero tiene redundancia por si esa cae y el tráfico de administración y producción que vaya por otra y si cae que el tráfico total de los diferentes servicios viajen como actualmente lo tienes.

    Un saludo.

    Reply
  17. 17

    Jose

    Hola José Luis:
    Después de todo este tiempo hoy he podido llevar a cabo una de las opciones que me comentabas (aunque sigue fallando).
    Lo que he hecho ha sido, en cada uno dde los dos servidores dejar una de las NIC para la VLAN de producción y la otra para la VLAN de almacenamiento deshabilitando las opciones de balanceo de carga y tolerancia a fallos.
    – El servidor 1 lo he pinchado a sus correspondientes interfaces (una NIC a la VLAN de produccion y la otra a la VLAN de almacenamiento).
    – Al pinchar el servidor 2 a la VLAN producción todo sigue bien pero mi sorpresa ha sido al pinchar la otra NIC a la VLAN de almacenamiento ya que toda la red se ralentiza muchísimo y las maquinas virtuales con más tráfico de red pierden paquetes(más o menos 1 de cada 4) con lo que la comunicación con estas máquina se interrumpe cada dos por tres.

    No sé si esto te sugiere algo.

    Gracias y un saludo.

    Reply
  18. 18

    Florián Murillo

    Dejarme hacer unas preguntas estúpidas, sino las hago me da algo ¿Has cambiado el cable de red? ¿No tendrán la misma IP los puertos de kernel de los dos hosts?

    Reply
    1. 18.1

      José Luis Gómez

      Buenos días:

      Iba a realizar las mismas preguntas estupidas… así que no las veo tan estupidas. Da la sensación de usar mismo direccionamiento en ambas interfaces.

      Saludos.

      Reply
  19. 19

    Jose

    Hola:
    No. Los Kernel tienen IPs distintas.
    Lo único que coincide en los host es la puerta de enlace, que no sé si tiene algo que ver en el problema.

    Saludos.

    Reply
  20. 20

    Julio

    Buenas noches. Me gustaría hacer una pregunta sobre una configuración que no me funciona. Tengo instalado ESXi 4 y he intentado de varias maneras cambiar la ID de VLAN para distintos port-group y siempre me sale VLANID(opcional) dejándome seleccionar a none(0) o ALL(4095). Conseguir ayer conectarme al server ESXi por ssh y cambiar esos ID con el comando esxcfg-vswitch (creo que era ese ) pero no aparece el cambio en la consola de ESXi. Después configuré un 2960 de Cisco con las mismas VLAN que el switch virtual asi como el enlace troncal pero no funcionó.
    Mi dudas son:
    – Si configuro el 2960 como VTP server afectará al funcionamiento correcto del switch virtual
    – Cómo hago para cambiar al modo VST al switch virtual y que me salga la opción de poner las VLAN ID?.
    – Y la mas importante qué hago mal ?

    Muchas gracias.

    Reply
  21. 21

    Florián

    @Julio, ¿puedes copiarnos la config del interfaz del Catalyst?

    Reply
  22. 22

    Julio

    Creo recordar que es un 2960G (24xgigabit)
    interface GigabitEthernet 0/1
    switchport mode trunk
    switchport nonegotiate
    switchport trunk allowed vlan 10 , 20

    Lo que no sé es cómo activar en esxi el VST para poder poner las VLAN a los por-group.

    Gracias Florían.

    Reply
    1. 22.1

      Waldemar Pera

      @Julio, tal vez llego un poco tarde. Es correcto que al momento de seleccionar sólo aparecen dos opciones, pero que lo debes hacer es escribir directamente el ID de la VLAN y listo.

      En cuanto a la configuración de EtherChannel, las recomendaciones de Florián son las adecuadas. En mi caso:

      interface Port-channel1
      switchport
      switchport trunk encapsulation dot1q
      switchport trunk native vlan 98
      switchport trunk allowed vlan 98,99
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk
      !
      interface GigabitEthernet1/29
      switchport trunk encapsulation dot1q
      switchport trunk native vlan 98
      switchport trunk allowed vlan 98,99
      switchport mode trunk
      switchport nonegotiate
      speed 1000
      duplex full
      channel-group 1 mode on
      !
      interface GigabitEthernet1/30
      switchport trunk encapsulation dot1q
      switchport trunk native vlan 98
      switchport trunk allowed vlan 98,99
      switchport mode trunk
      switchport nonegotiate
      speed 1000
      duplex full
      channel-group 1 mode on
      !

      Configurando además IP Hash en el vSwitch como método de balanceo todo opera correctamente.

      Saludos.

      Reply
  23. 23

    Miguel

    Me quede con la duda… en mi caso tengo vmware ESXi ver. 4.1.0 con 2 tarjetas de red fisicas, la Gb0 esta conectada al G1(vlan1 -Lan-) y la Gb1 esta conectada al G2(vlan2 -Publica-), la idea que tengo es virtualizar 2 servidores de linux, dns y correo, asi que monté 2 virtuales con CentOS 5.5, le asigne una ip privada a la NIC1 y a su vez le asigné una ip publica a la NIC2… todo funciono bien, realizaba un ping desde la virtual hacia mi puerta de enlace y hacia internet y respondian correctamente en ambas interfaces, incluso descargue software, navegue, todo ok… pero al momento de reiniciar la virtual dejo de responder ambas tarjetas de red… lo unico que responde es el ping hacia su misma ip, ya no “veo” mi puerta de enlace ni tengo salida hacia internet y fue la misma situacion con el 2o servidor que virtualice… despues de reiniciar tambien tuve este problema… espero no haberlos enredado :P ;

    Lo curioso es que monte un windows 2003, con sus 2 tarjetas, le puse una ip en la privada y otra ip en la publica y ambas funcionan correctamente, responden correctamente a sus puertas de enlace, hacia internet, navego, etc y ya reinicie “N” cantidad de veces el equipo y no presenta el mismo problema… alguna sugerencia y/o tip??? De antemano gracias por la ayuda, excelente blog!

    Reply
    1. 23.1

      Jose Maria Gonzalez

      Hola Miguel,

      Si te funcionaba antes, debería funcionar también ahora, no crees?

      Revista tu configuración de red y routing dentro de la máquina virtual Linux y la configuración de networking (vSwitch, VLANs, vmnics, etc) en el servidor de VMware ESX/ESXi.

      Rgds,
      J.

      Reply
      1. 23.1.1

        Miguel

        Gracias x contestarme, pues ya lo volvi a revisar a conciencia… switches, puertos, configs en las NICS y sigue en las mismas… monte otras maquinas en windows y funciona correctamente… :| en fin… seguire averiguando que pasa y ya les contare que encontre, saludos!

        Reply
        1. 23.1.1.1

          José Luis Gómez Ferrer de Couto

          Hola Miguel:

          ¿Lo tienes con direccionamiento estático o con DHCP? Si lo tienes con DHCP prueba a la hora que te falle poner la dirección en modo estático y a ver si responde.

          Un saludo.

          Reply
          1. 23.1.1.1.1

            Miguel

            Gracias Jose Luis, ya encontré el problema… en mi virtual switch 2, en el port group tenia especificado el vlan ID 2, este puerto ya estaba configurado en la vlan 2, no como trunk (es un switch de la serie Catalyst 500 y vaya problemas que me dio :S si tienen la posibilidad de adquirir un switch de la serie 2960 que mejor :D) y pues le quite el vlan ID en None y santo remedio (y).

            Lo curioso es que aun con la config anterior, funcionaba correctamente en windows… wtf?!, en fin, gracias por la atencion y sigamos virtualizando!!! saludos!

  24. 24

    Jorge Daniel

    hola Jose

    Por que no puedo instalar Vcenter en un AD? cuales son la razones tecnicas?.

    vcenter utiliza pto UDP 902 para hearbeat? no entiendo ya que los puertos UDP no son orientados a conexion y no recibiria retroalimentacion del vecenter para detectar que esta arriba y funcionando, no deberia ser TCP?

    gracias por tu ayuda

    Reply
    1. 24.1

      Jose Maria Gonzalez

      Hola Jorge,

      Muy buena pregunta. Hay algunas con lo que mejor te adjunto el enlace de mejores practicas para instalar vCenter.

      http://kb.vmware.com/kb/1022101

      Rgds,
      J.

      Reply
  25. 25

    Roberto Lara

    Buenas tardes,
    Estoy intentando configurar el etherchanel de un cisco 3750 y un VMWARE ESX4.1.
    Si el etherchanel del swith lo hago asi NO funciona:

    interface range GigabitEthernet 1/0/5-7
    description BORGES
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 54
    switchport mode trunk
    switchport nonegotiate
    channel-group 2 mode on

    Interface Port-channel2
    description BORGES
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 54
    switchport mode trunk
    switchport nonegotiate

    Y asi SI funciona:

    interface Port-channel2
    description BORGES
    switchport access vlan 54
    switchport mode access

    interface range GigabitEthernet 1/0/5-7
    description BORGES
    switchport access vlan 54
    switchport mode access
    channel-group 2 mode on

    SE OS OCURRE ALGO¡¡¡He probado de todo ya….

    Reply
    1. 25.1

      José Luis Gómez Ferrer de Couto

      Hola Roberto:

      Siempre hay que crear antes el Port-channel y luego asignar los puertos miembros a este.

      Un saludo.

      Reply
  26. 26

    Roberto Lara

    Si eso es lo que he hecho…
    Lo unico que al copiar y pegar pues lo he puesto encima …
    Se te ocurre algo??
    Gracias¡¡¡

    Reply
  27. 27

    Florián

    @Roberto, si te funciona con el “mode access” es que no has informado ninguna VLAN en el port-group, miratelo una vez mas, seguro que tienes el problema delante y como le has dado tantas vueltas no lo ves.

    Reply
  28. 28

    Roberto Lara

    Donde puedo informar las Vlan en el port-group???
    No entiendo bien lo que me dices..
    Muchas gracias por todo¡¡¡
    Saludos¡¡

    Reply
  29. 29

    Roberto Lara

    Las he declarado en el VMWARE ESX en el Vsiwtch y VmNetwork
    En el VMkernel y Service console no…
    Puede ser esto??

    Reply
  30. 30

    Florián

    @Roberto, si un interfaz ethernet de un switch Cisco está configurado como trunk (tu primera configuración) todo el tráfico que sale por el vmnicX conectado a ese puerto físico ha de tener un tagging de VLAN, si al vmnicX le conectas un puerto de kernel, en sus propiedades le has de especificar VLAN y si es un port´group de máquinas virtuales tambien. Las VLANs que informes en los puertos de kernel y los port-group han de estar permitidas en el puerto físico con el comando “allowed” que has añadido, SOLO esas VLANs tienen permitidas el paso. Espero que este “rollo” te sea de utilidad.

    Reply
  31. 31

    yoelvys

    hola no podria decir que soy novato en el tema del trabajo con este tipo de servidores porque ni eso soy, pero tengo uno en mi red y tengo que aprender, el caso segun lo que he estado viendo el servidor tiene 2 tarjetas de red mi problema esta en que no se como conectar el internet a una y por la otra ofrecerle el internet a mis usuarios, como hago actualmente con una pc normal con dos tarjetas te red. pues tengo un servidor System x3650 M2 y lo tengo para que ocupe espacio hasta ahora en mi local. gracias

    Reply
  32. 32

    Florián

    Yoelvys, tendrás una VM con 2 virtual NICs, cada una de ellas la has de conectar a un port-group, por una los PCs encontrarán esta VM como gateway y por la otra tendrás salida a internet, cada port-group lo conectarás a una vmnic (opción 1) o bien a diferentes VLANs en la misma vmnic o en diferentes. Espero haberme explicado.

    Reply
  33. 33

    leonardo

    buenos días, soy novato en el tema de redes y me toca administrar un server donde tengo un ESX corriendo con una ip (conexion WAN), dentro del ESX tengo varias maquinas virtuales donde una de ellas es un ISA server el cual esta conectado directamente otra ip (conexion WAN), que esta dentro de la misma subred del ESX, el planteo que tengo es el siguiente yo ahora quiero poner un router antes del ISA server, me comentaban que para hacer eso necesitaría contratar una ip mas al proveedor y que la misma este dentro de la subred de la anteriores, ante ello se me ocurrió: porque no usar solo una ip y que la misma entre directamente a este nuevo router, luego en el mismo configurar la LAN, en la cual una LAN direccione al ISA server, y la otra direccione al ESX (analizando que puertos usaría, hago nateo, calculo que el administrador de ESX no usara más de uno o dos puertos, y todos los demás puertos lo redirijo al ISA), con lo cual mi red interna de maquinas virtuales quedaría sin modificaciones, mi red WAN del ISA server seria una ip privada provista por la LAN del router, sera esto posible? desde ya gracias y disculpen por lo largo que se hizo la consulta.

    Reply
  34. 34

    Florián

    @leonardo, me falt un dato, las VM que tienes “detras” del proxy, ofrecen servicios en Internet o utilizan el proxy para “salir” solamente. Gracias.

    Reply
  35. 35

    leonardo

    Florián, buenos días, en las maquinas virtuales tengo servidores de base de datos (en los cuales tengo clientes que consultan dichas bases) y tengo algunos otros clientes que se conectan por rdp a una de las maquinas virtuales.
    Desde ya muchas gracias por tu tiempo.
    Saludos

    Reply
  36. 36

    Florián

    @leonardo, si lo he entendido, solo necesitas llevarte la IP de WAN al router y cambiar la configuración en el proxy.

    Reply
  37. 37

    Gino Anticona

    Estimado Florián,
    Cuál sería la configuración más recomendable implementar para dos switchs HP BLc GbE2c LY 2/3 Switch y un Switch core Cisco o HP, entendiendo que dentro del chassis c3000 se tendrá servidores Blade con cuatro puertos de red y con VMware vSphere 5 instalado.
    Saludos Cordiales.
    Gino Anticona.

    Reply
  38. 38

    Florián Murillo

    Hola Gino, imagino que querrás escalabilidad y alta disponibilidad ¿Has pensado en vPC? el próximo viernes mi post irá dedicado a este tema, espero que te ayude.

    Reply
  39. 39

    Carlos

    Hola a todos,
    Soy novato en esto y no sé la mejor forma de conectar un servidor vmware con switches Cisco.
    lo que quiero es conectar un vswitch de VM con 4 adaptadores a dos Cisco independientes. ¿cuál sería la mejor forma de hacerlo?. Creo que están las limitaciones de al ser switches independientes no puedo crear eterchannel con los cuatro puertos, y al ser más de un enlace por switch necesito eterchannel. Se me ocurre poner tres enlaces a un switch con un eterchannel y otro enlace al otro y que éste estuviera en standby, pero al configurar vmware para etherchannel tengo que poner balanceo IP HASH y éste no admite adaptadores en standby, que lío..
    Gracias de antemano

    Reply

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Una Web de JmgVirtualConsulting empresa especializada en formación Oficial VMware y servicios de Virtualización | Copyrights © 2014