Servicios Virtualización y Cloud Computing

Sobre el autor

Adolfo Muñoz Moratalla

Adolfo Muñoz Moratalla, es Director Ejecutivo de Custom Professional Hosting, empresa dedica a la personalización de sistemas de hosting, sistemas de virtualización y alta disponibilidad para hosting.

Artículos Relativos

29 Comentarios

  1. 1

    Felipe

    Hola amigo,

    Una pregunta:

    El procedimiento esta perfecto te agradezco el aporte. Pero tengo una pregunta que hacer si al instalar todo el XenServer solo me aparecen en Storage (SR):DVD Drives y Removable Drives.

    No me aparece ningun Local Storage y la verdad no se que mas hacer, estoy un poco desesperado. Realice el procedimiento anterior pero me dice que el disco esta siendo usado por el Host.

    Espero me halla hecho explicar y ojala y me puedas ayudar.

    Saludos

    Responder
  2. 2

    Anthony Collins

    Hola Felipe, aqui te dejo estos tres comandos que te pueden ayudar tanto a ver tu local storage como a realizar modificaciones sobre el mismo:

    # xe sr-list
    # xe pbd-unplug uuid =
    # xe pbd-plug uuid =

    Un saludo.

    Responder
  3. 3

    Felipe

    Gracias,

    Lo que pude determinar de todo esto fue:

    .Los discos P-ATA no son reconocidos por el XenServer o por lo menos no los pude hacer funcionar
    .Y que al hacer la instalacion del S.O. si selecciono en la parte que pregunta sobre el Storage, llego a seleccionar la casilla “Thin optimized XenDesktop” ya sea con un disco S-ATA tampoco lo reconoce, osea no hay que seleccionar dicha casilla.

    Agradezco la respuesta.

    Saludos

    Responder
  4. 4

    ruben

    Hola a tod@s.

    He leido este post y me parece que puede que me sirva para solucionar mi problema, ya me diréis. Os comento:

    Estoy intentando hacer un backup de mi xenserver, pero a la hora de realizar el snapshot me da un error de falta de espacio en mi SR. Con este post puedo añadir un nuevo disco duro slave o un usb masivo en mi servidor aumentando asi mi capacidad de almacenaje.

    Es posible que funcione y me solucione el problema?

    Un saludo y gracias por su atención.

    Rubén.

    Responder
    1. 4.1

      Adolfo

      Hola Rubén,

      Me temo que no es posible, el snapshot se almacena en el mismo SR donde está alojado el disco de la VM. No hay otra posibilidad.

      Un saludo,

      Adolfo.

      Responder
      1. 4.1.1

        ruben

        Hola Adolfo.

        Gracias por tu respuesta.

        Entonces cómo puedo reducir el tamño del SR dond ese aloja mi VM? Lo he intentando desde el xencenter pero me dice qeu no está permitido.

        Alguna sugerencia?

        Gracias por tu atención.

        Rubén.

        Responder
  5. 5

    ruben

    Hola otra vez.

    Y si elimino mi datostore de 400Gb y creo otro de menor tamaño? Perderé mis VM o sólo elimino el SR asociado a ellas?

    Un saludo y gracias.

    Rubén.

    Responder
  6. 6

    roberto

    Buenas noches, Adolfo,esta excelente el blog los que iniciamos en esto nos cae de maravilla, solo un detalle, que posibilidad tienes de ser un poco mas explicito con respecto al comando de agragar un disco nuevo, no le capto al comando en su parte de id, se te fijas en la imagen que pones como referencia tienes 3 discos sda,sda1, sda2, sda3, cual es el id, y cual pones.
    mi problema es que tengo dos disco duros pero solo uno me pone bajo el esquema por default lvm, pero el otro no lo veo ahi, pero si utilizo el comando fdisk -l , si logro verlo, pero no puedo usarlo a lo mejor tengo que ponerlo como tienes el comando, pero no se como usarlo, disculpa la molestia y espero tu ayuda si es posible gracias

    Responder
  7. 7

    Ruben

    Hola de nuevo.

    Hace tiempo que no me pongo en contacto con vosotros, pero es que me ha surgido un nuevo problema:

    Necesito instalar un VM Debian 6 en Xen 6.Mi problema surge porque las templetas que incorpora Xen 6 o Xen5 no soporta el debian 6 con entorno gráfico que intento instalar. Ante cual me surgen varias dudas:

    1.- Existe alguna forma de crear una VM Debian 6 con Xen 5 o 6?, la imagen la lee de CD o de .iso me da igual.
    2.- Viendo que no lo consigo de esta forma he creado un VM Debian 6 en Virtual Box y otra en VMWare, con el objetivo de exportala a Xen 6. El problema esta cuando uso Xen Convert, para transformar el .vmdk en xva. Durante la transformación me da error y no consigo avanzar tampoco.

    Por tanto estoy buscando alguna solución que me permita exportar o crear un VM Debian 6 en Xen 6, pero no doy con la tecla. No me importaria intentarlo con Esxi.

    Alguna sugerencia?

    Gracias por su tiempo.

    Un saludo.

    Rubén.

    Responder
    1. 7.1

      Ferran

      Hola Ruben,
      Tienes la opción de instalarlo como hvm (sin ser paravirtualizada) mediante el template “Other install media” y entonces será similar a las que tienes en Virtual Box, tus X funcionaran correctamente, etc.

      Una vez la tengas funcionando puedes ponerle un kernel Xen e instalar las XenTools y modificar la configuración de la máquina virtual para que arranque paravirtualizada.

      Cualquier duda aquí estamos para ayudarte.

      Responder
  8. 8

    Ruben

    Hola Ferran.

    Muchas gracias por tu report, he conseguido instalar el debian 6 sin problema, salvo que he tenido que user una .iso multi-arch.

    Ahora mi problema es otro, no soy capaz de montar mi usb en Xen para que mi VM Debian 6 lo pueda ver. He seguido los pasos del manual , pero me da error siempre en el xe create type=…. Me dice que no found name-label, y eso que he apuntado el id del usb, incluso he probado con el uuid que pone en el sencenter, pero nada de nada.

    Alguna sugerencia.

    Rubén.

    Responder
    1. 8.1

      Ferran

      Para poder seguirte bien necesitaría que pegaras los errores que te da:
      En el Xenserver donde tienes el USB
      1.-la salida del dmesg que te muestra el uuid del disco USB o bien el ejecutar # blkid
      2.- ls /dev/disk/by-id/
      3.- xe pbd-list

      Saludos

      Responder
  9. 9

    Ruben

    Hola Ferran.

    Al final lo he conseguido. El USB aparece en el xencenter como disco local, mi problema es que mi VM Debian 6 no tiene acceso a este nuevo disco local. Que tengo que hacer para poder tener acceso a él desde VM Debian 6?

    Un saludo y muchas gracias

    Rubén..

    Responder
  10. 10

    Ferran

    Hola Rubén,
    Te recomendaría que leyeras el post de hoy sobre XenServer: https://www.josemariagonzalez.es/2011/10/05/como-instalar-citrix-xenserver-6.html Aparte del video de la instalación de la nueva versión, explico como XenServer (XAPI) gestiona los discos.

    Directamente las maquinas virtuales no pueden “ver” el disco USB, tendrás que crear un VDI dentro del disco USB y luego podrás conectarlo a tu maquina virtual desde XenCenter.

    Saludos

    Responder
  11. 11

    Ruben

    Hola Ferran.

    He visto los videos pero no me ha quedado muy claro, en mi caso he conseguido que me reconozca el usb como sr “disco local 2”, lo que pasa es que no sé cómo seguir.

    Lo que he visto en el video es que esa nueva biblioteca de imagenes iso la usa para crear otra VM. Entiendo que usa el espacio del usb (en mi caso) para crear un nuevo sr local donde instala una nueva vm, pero yo no quiero eso. Lo que pretendo es que mi vm debian 6 pueda acceder al contenido del usb, el dvd lo monta bien, pero el usb no.

    Entonces no sé que pasos debo seguir para crear un vdi dentro del usb para poder acceder a esos contenidos dentro de la vm debian 6.

    Tengo los conceptos un poco confusos, sorry.

    Muchas gracias por tu tiempo y paciencia.

    Un saludo.

    Rubén.

    Responder
    1. 11.1

      Ferran

      Disculpa haber tardado tanto en contestar. Prueba lo siguiente:
      1. Pon el USB en el host donde esta corriendo la VM
      2. En XenCenter ves a la VM que quieres usar el USB y ves al apartado Storage
      3. Click en el botón Attach, deberías ver el disco USB para añadirlo
      4. Marcas dicho disco y le das attach
      5. Entras en la VM i miras con un fdsik/dmesg en que disco de la VM tienes el disco.

      Saludos

      Responder
  12. 12

    Ruben

    Hola .

    Ante todo darle las gracias por leer el correo.

    Paso a comentarle mi problema, aunque no sé si es el sitio adecuado para ello. Tengo instalado un Xen Server 5.6 Fp1 en cual corren dos wk8 server R2, uno de ellos, digamos el B tiene isntalado el TMG 2011 para el control de acceso y salida a internet. Además tengo instalado el role de enrutamiento y acceso remoto, entre otros. El problema surge cuando reinicio esta máquina virtual wk8 server R2 , me desistala en servicio de enrutamiento y acceso remoto, teniendo que volver a instalarlo cada vez que reinicio dicha máquina.

    Puedo ser debio al TMG 2011? Llevo unos días dándole vueltas y no consigo solucionarlo, alguna idea?

    Gracias por todo y espero que me puedan ayudar.

    Un saludo.

    Rubén.

    Responder
    1. 12.1

      Ferran

      Hola Rubén.

      La verdad es que dezconozco el porqué de tu problema, entiendo que no tendria que ser un tema relacionado con XenServer ya que en el hypervisor está por debajo y windows 2k8 r2 esta soportado por Citrix XenServer. Prueba a ver que no tengas cambios de MAC al reiniciar la maquina.
      Saludos

      Responder
  13. 13

    Xoan

    Tengo un Xen Server 5.5.0 y quiero actualizarlo, pero por alguna razon me falla las actualizaciones. La otra opción es reinstalar, pero no quiero perder las maquinas virtuales. Hay posibilidades de reinstalar sin perder la partición donde estan alojadas las maquinas virtuales?

    Un saludo.

    Responder
  14. 14

    Rubén

    Hola a tod@s.

    No sé si este es el lugar adecuado para esta cuestión.

    Ante todo dar las gracias por vuestro tiempo.

    Tengo un problema con la siguiente estructura: Tengo un xenserver 5.6 en el cual corren un w2k8 R2 y un IPCOP. El w2k8 r2 tiene tres tarjetas de red: IN (entrada de usuarios al dominio), OUT-IPCOP (conectada un IPCOP) y la tercera OUT-FREENASS, apunta a un FREE NASS. Las ips son:

    IN : 172.16.1.1

    OUT-IPCOP: 10.10.0.1

    OUT-FREENASS: 172.16.2.1

    El problema surge cuando quiero que esa misma tarjeta IN pueda conectarse con la tarjeta OUY-IPCOP usando un “bridge” y con la OUT-FREENASS usando un NAT. No sé cómo asignarle a una mismo tarjeta dos roles distintos. Uno para la OUT-IPCOP: 10.10.0.1 con “bridge” y otro a la OUT-FREENASS: 172.16.2.1 con NAT.

    El tema del “bridge” lo entro comillo por que no sé en verdad qué es lo que necesito, ya que lo yo quiero es que las ip que entran por IN (usuarios autenticados) sean las mismas que llegan a OUT-IPCOP: 10.10.0., ya que en el IPCOP tengo instalado un delay pools que controle el flujo de descarga por ip. Es por eso que debo mantener las ip de entrada en el IPCOP, ya que si hag un NAT todos las ip de entrada se transforman a una única ip.

    Este es el problema que tengo y al cual no encuentro solución. Acepto cualqiuier sugerencia incluida el cambio de arquitectura.

    Un saludo y muchas gracias.

    Rubén.

    Responder
    1. 14.1

      Jose Maria Gonzalez

      Hola Rubén,

      Gracias por tu comentario. Es mejor que dejes este tipo de preguntas en nuestro foro de virtualización dedicado a tal fin:

      Puedes encontrarlo en esta dirección:

      Rgds,
      J.

      Responder
  15. 15

    Julio

    Hoy llegó un servidor DELL a la oficina, dicho servidor tiene 4 discos de 500GB los cuales están configurados con RAID5.

    Instalé el Xen Server 6.0 en una usb para dejar los 1.35 TiB del RAID libres para almacenar las máquinas virtuales.

    En cuanto tenga oportunidad haré los pasos que se indican en el post, seguro me servirá cierto :P?

    Saludos!

    Responder
  16. 16

    manuel

    Hola mi duda es la siguiente, quiero hacer con los scripts que antes nos habeis mostrado backups de mis 2maquinas virtuales que tengo en mi xen 5.6. el problema es que no puedo hacer snapshot por falta de espacio local. Mi pregunta es la siguiente, tengo alguna opcion de comprar una nas y añadirla de alguna forma como si fuese espacio local para que me lo detecte xen y me deje hacer tanto el snapshot como la exportacion???

    y si no fuese asi con un disco usb???

    agradeceria vuestra ayuda, un saludo a ferran y a jose maria

    gracias

    Responder
    1. 16.1

      Ferran Serafini

      Hola Manuel,

      Si compras un NAS lo mejor es que lo utilices como Storage Repository directamente y guardas los backups en el disco local.

      SI no tienes espacio en el disco donde tienes la VM, no puedes hacer snaps, para ello necesitas disponer de más espacio libre. Como al final es LVM puedes añadir más disco de forma dinámica, pero no te recomiendo mezclar volúmenes lógicos de por ejemplo un disco USB y un SATA, sino mejor otro disco duro igual más y juntar los volúmenes.

      Saludos

      Responder
  17. 17

    Antonio

    Buenas tardes a todos.

    Tengo el siguiente problema, al intentar hacer Backup de mi maquina virtual me dice que no se puede por que no hay espacio suficiente, comprendi por lo que lei que es por que se instala en el mismo lugar que la instalacion original, cual es la solucion para este problema?

    Por su apoyo muchas gracias.

    Saludos!!!

    Responder
  18. 18

    Jhonny

    Buenas tardes a todos.
    deseo saber si despues de una reinstalacion de xencitrix podemos recuperar la informacion del local storage?
    pues yo puedo ver el espacio de las vm pero no logro montar los discos tengo 4 discos de 2To cada pero no conosco el metodo para montar los discos sin perder las vm que estan al interior
    deso saber si alguien sabe como hacerlo
    mil gracias

    Responder
  19. 19

    Gabriel

    Hola a todos, los molesto porque tengo un inconveniente. Durante las mañanas cuando hago un control de los discos atachados mediante USB siempre encuentro que hay uno que no esta y lo atacho de forma manual. Lo que queria saber es que si eciste algun script para que se ejecute a una determinada hora el cual verifique si se encuentra dicho disco y sino lo esta que lo atache de forma automatica.
    Desde ya muchas gracias por su atencion y aguardo su respuesta.

    Saludos.
    Gabriel.

    Responder
  20. 20

    manuel

    Me sumo a la anterior petición,

    gracias.

    Responder
  21. 21

    Uriel

    Buenas tardes.
    Comento mi problema.
    Tengo un server Fujitsu con dos RAID , en RAID 1 he montado mi xenserver y un RAID 0 para poder añadir el nuevo storaje.
    Veo tu Post y parece bastante intuitivo, pero mi pregunta es como puedo sacar el uuid del disco que quiero poner como nuevo storaje, en mi caso seria /dev/sdb.
    hay que montarlo en algun lado?? , ando algo perdido.

    Un saludo.

    Responder

Deja un Comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Una Web de JMG Virtual Consulting, especialistas en Soluciones de Virtualización y Formación Oficial VMware y OpenStack | Copyrights © 2017