Servicios Virtualización y Cloud Computing

About the author

Adolfo Muñoz Moratalla

Adolfo Muñoz Moratalla, es Director Ejecutivo de Custom Professional Hosting, empresa dedica a la personalización de sistemas de hosting, sistemas de virtualización y alta disponibilidad para hosting.

Related Articles

15 Comments

  1. 1

    Daniel

    Hola Adolfo,

    En algunas ocasiones he tenido problemas con este comando para crear un repositorio ISO en Storage Local, sobre todo cuando lo he intentado montar sobre un volumen lógico. Te indico una forma de hacerlo que no me ha dado ningún problema:

    # xe-mount-iso-sr /var/opt/xen/isos -o bind

    Reply
    1. 1.1

      Adolfo

      Muchas gracias Daniel por tu aportación.

      Un saludo,

      Adolfo.

      Reply
  2. 2

    Miguel

    Buenas,

    He creado el repositorio sin problemas, pero al subir con WinSCP la ISO del windows 2008 r2 (ocupa 2,88 Gb) me da error. Solo me permite subir archivos de más de 1,2 Gb.

    La version de XenServer es la 5.6 SP2 y el servidor un Dell T110.

    Gracias

    Reply
    1. 2.1

      Adolfo

      Hola Miguel,

      Probablemente te hayas quedado sin espacio en el raiz. Haz un df -h para verificarlo. Si hay espacio e inodos suficientes no hay ninguna limitación por lo que no tienen que haber problemas.

      Saludos.

      Reply
      1. 2.1.1

        Miguel

        Buenas noches,

        Efectivamente no tiene espacion en disco suficiente, pero no lo entiendo porque tengo solo un windows server 2008 core montado (24Gb de disco duro asignado) y el disco duro del servidor es de 250Gb.

        Lo que me devuelve el comando df -h con el repositorio de ISOs vacio es esto:

        Filesystem Size Used Avail Use% Mounted on
        /dev/sda1 4.0G 3.0G 827M 79% /
        none 380M 0 380M 0% /dev/shm
        /opt/xensource/packages/iso/XenCenter.iso
        44M 44M 0 100% /var/xen/xc-install

        A parte e intentado hacer un RAID-0, no se si esta bien montado, ya que el servidor al arrancar antes de instalar el xenserver me muestra el RAID online, pero al instalar el xenserver ve los discos duros sueltos, y tras reiniciar el RAID aparece como failed, aunque desde la consola del xenserver en el servidor el local storage tiene la capacidad del RAID-0 (411 Gb). La controladora RAID es una PSEC100 embebida en la placa base que permite RAID-0 y RAID-1.

        Gracias por la ayuda

        Reply
  3. 3

    gaprosur

    hola, muy util la guia.

    Seguí los pasos, todo sin problema pero al crear la nueva vm y querer usar el nuevo ISO, no lo veo.

    Solo veo Storage que creé de nombre ISOs, pero ese no se puede seleccionar, espero alguien pueda ayudarme.

    Reply
  4. 4

    gaprosur

    ok, reinicie el servidor y ya puedo usar el .ISO que subi usando el Winscp.

    muchas gracias por la guia

    Reply
  5. 5

    Javier

    buen dia
    tengo un problema
    hice los pasos tal como aqui los muestra y cuando esta a punto de terminar la copia por WinSCP me marca un error numero 6 o algo asi, podria ayudarme por favor.

    Reply
    1. 5.1

      gaprosur

      Igual que arriba, te pudiste haber quedado sin espacio en raiz corre el comando df -h
      muchas veces los logs usan mucho espacio, yo elimine algunos y me libero mas de 1gb.

      Reply
  6. 6

    k421k1

    hmmm, veo que varios tienen el mismo problema de espacio. Les comento mi solucion.

    1º Cree una particon de 100 GB de uno de mis discos duros para destinarla a archivar imagenes de CD, esta se ubica en /dev/sdc1
    2º Formatie como ext3 la particion /dev/sdc1
    3º cree las carpetas donde dejaria las ISOs, /var/opt/xen/iso
    4º la registre en /etc/fstab
    5º Monte la particion
    6º Cree el SR comando: xe sr-create name-label=ISOs type=iso device-config:location=/var/opt/xen/isos device-config:legacy_mode=true content-type=iso

    FIN
    Como la particion esta informada en fstab no tendran que volverla a montar.

    Reply
  7. 7

    Wilmer

    Hola.
    de antemano muy bueno las guias XenServer… Gracias!

    yo tengo en problema que no puedo conectarme un archivo con imagenes iso en red linux. intento por xencenter y me sale error.
    use xe sr-create content-type=user type=nfs name-label=”ISO_REDs” shared=true device-config:server=Ip_server device-config:serverpath=path

    y no crea, lo ilogico es que ayer funcionaba correctamente con cencenter

    Gracias de antemano por la ayuda

    Reply
  8. 8

    Eduardo Cerdas Moya

    Hola buenas, soy novato en XenServer y quiero hacer una especie de laboratorio en mi casa con Xenserver en una maquina Core 2 Duo de 2.33GHz, 1 GB de RAM dos discos duros uno de 178 Gb y otro de 78GB, es factible montarlo bajo estas características. Muchas Gracias y muy bueno este post

    Reply
    1. 8.1

      Jessy

      Al copiar una imagen al servidor remotamente me sale esto:
      Error general (El servidor debe haber facilitado más información)
      codigo de error: 4
      Mensaje de error desde el servidor: Failure
      Codigo de la petición: 6

      Por favor necesito ayuda en esto, es de suma urgencia
      Gracia

      Reply
      1. 8.1.1

        Jose Maria Gonzalez

        Jessy, puedes contratar nuestro soporte Premium en esta pagina para recibir soporte en menos de 4 horas.

        http://www.jmgvirtualconsulting.com/contacto/

        Gracias,
        Rgds,
        J.

        Reply
  9. 9

    Adrian

    Agradezco mucho primero que todo a Adolfo por este truco de tanta utilidad para nosotros los que creemos en Las virtualizaciones con Citrix, y segundo a Gaprosur porque con los aportes de ambos pude lograr las instalaciones que queria con mis propias Isos en mis maquinas virtualizadas. Este Truco funciona perfecto….

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Una Web de JMG Virtual Consulting, especialistas en Soluciones de Virtualización y Formación Oficial VMware y OpenStack | Copyrights © 2016